EtherChannel(PAgP)
・EtherChannelを使って複数本のリンクを束ねて1本として扱う
・EtherChannelの実行プロトコルとしてPAgPを使う
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1 ←下の設定を入れると自動的にできる
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
 channel-group 1 mode desirable ←このポートでPAgPを動作
!
interface FastEthernet0/12
 switchport mode dynamic desirable
 channel-group 1 mode desirable ←このポートでPAgPを動作
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
line vty 5 15
!
end

SwitchBのコンフィグ
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1 ←下の設定を入れると自動的にできる
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
 channel-group 1 mode desirable ←このポートでPAgPを動作
!
interface FastEthernet0/12
 switchport mode dynamic desirable
 channel-group 1 mode desirable ←このポートでPAgPを動作
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
line vty 0 4
 no login
line vty 5 15
 no login
!
end
確認
リンク同士がネゴシエーションをしてEtherChannelを実現することもできます。
ここでは,シスコ独自のリンクアグリゲーション・プロトコルであるPAgP(Port Aggregation Protocol)を使う方法を見てみます。

●PAgPを使ってEtherChannelを実現する
EtherChannelを実現する方法は,以下の三の方法があります。

・固定的(強制的)に設定する
・PAgPというシスコ独自のプロトコルを使う
・LACPというIEEE802.3ad標準のプロトコルを使う

PAgPは,ポートの速度,全2重/半2重,VLAN番号,トランクなどを判断して,EtherChannelが構成可能かどうかを判断するプロトコルです。
ここでは,PAgPを使う方法を見てみましょう。

●PAgPの設定方法
PAgPを使う場合も,インタフェースでchannel-groupコマンドを使います。
ただ,PAgPを使う場合に指定するモードは,「desirable」または「auto」です。

【PAgPのモード】
・desirable…PAgPのネゴシエーション要求パケットを自ら送るモード。
・auto………自らネゴシエーション要求パケットは送らないが,ネゴシエーション要求が来たら受け付ける

PAgPによってEtherChannelgが成立するのは,両端のポートが,「desirable同士」または「どちらか一方がdesirableでもう一方がauto」のときです
両方ともautoにした場合は,両方ともネゴシエーション要求が出ないので,EthrChannelにはなりません。

このラボ・シナリオでは,SwitchAもSwitchBも以下のように設定します。
SwitchA(config)#interface range fastEthernet 0/11 - 12
SwitchA(config-if)#channel-group 1 mode desirable

●動作の確認
設定したら,動作を確認してみましょう。
show etherchannelコマンドで,EtherChannelの様子を確認してみます。
SwitchA#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P)
「Protocol」の部分が「PAgP」となって,確かにPAgPが実行されているのがわかります(上の赤字)。

では,debugコマンドで,もう少し詳しく検証してみましょう。
debug etherchannlel detailコマンドを入力してみます。
SwitchA#debug etherchannel detail
PAgP/LACP Shim Details debugging is on
SwitchA#
*Mar  8 23:54:24: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:24: FEC: returning agport Po1 for port (Fa0/12)
*Mar  8 23:54:25: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:25: FEC: returning agport Po1 for port (Fa0/12)
*Mar  8 23:54:26: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:26: FEC: returning agport Po1 for port (Fa0/12)
*Mar  8 23:54:27: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:27: FEC: returning agport Po1 for port (Fa0/12) 
*Mar  8 23:54:28: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:28: FEC: returning agport Po1 for port (Fa0/12) 
*Mar  8 23:54:29: FEC: returning agport Po1 for port (Fa0/11)
*Mar  8 23:54:29: FEC: returning agport Po1 for port (Fa0/12)
(以下略)
1秒間隔で,Fa0/11とFa0/12の疎通をチェックしているのがわかります。

では次に,PAgPのやりとりの様子を見てみましょう。
SwitchAに,debug etherchannel eventコマンドを入力しておきます。
この状態で,SwitchBのPort-channel1インタフェースをいったんshutdownして,その後no shutdownさせてみます。
SwitchA#debug etherchannel event
PAgP/LACP Shim Events debugging is on
SwitchA# ←ここでSwitchBのPort-channel1インタフェースをno shutdownする
1w1d: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
1w1d: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
*Mar  9 00:03:33: FEC: pagp_switch_port_up: Fa0/11
*Mar  9 00:03:33: FEC: pagp_switch_invoke_port_up: Fa0/11
*Mar  9 00:03:33: FEC: pagp_switch_port_up: Fa0/12
*Mar  9 00:03:33: FEC: pagp_switch_invoke_port_up: Fa0/12
*Mar  9 00:03:35: FEC: fec_bundle: Fa0/12
*Mar  9 00:03:35: FEC: pagp_switch_add_port_to_agport_list: afb->nports++ = 1 [Fa0/12]
*Mar  9 00:03:35: FEC: fec_bundle: Fa0/11
*Mar  9 00:03:35: FEC: pagp_switch_add_port_to_agport_list: afb->nports++ = 2 [Fa0/11]
1w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed
state to up
1w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, changed
state to up
1w1d: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
1w1d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed sta
te to up
PAgPのやりとりが実行されて(青字の部分),その後,Port-channel1インtフェースがアップしているのがわかります。


●Catalyst 3550 マルチレイヤ スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEC
http://www.cisco.com/japanese/warp/public/3/jp/service/manual_j/sw/cat30/3550mscg/chapter30/16610_03_30.shtml

スイッチング・ラボ
IEEE802.1X認証の基本設定
IEEE802.1X認証(認証VLAN)
EtherChannel(固定設定)
EtherChannel(PAgP)
EtherChannel(LACP)
EtherChannel(レイヤー3)
SPAN