EtherChannel(固定設定)
・EtherChannelを使って複数本のリンクを束ねて1本として扱う
・EtherChannelは固定設定する(両者でネゴシエーションせずに強制的にEtherChannelを実行する)
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1 ←下の設定を入れると自動的にできる
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
 channel-group 1 mode on ←このポートをEtherChannelグループ1に定義(固定設定)
!
interface FastEthernet0/12
 switchport mode dynamic desirable
 channel-group 1 mode on ←このポートをEtherChannelグループ1に定義(固定設定)
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
line vty 5 15
!
end

SwitchBのコンフィグ
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1 ←下の設定を入れると自動的にできる
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
 channel-group 1 mode on ←このポートをEtherChannelグループ1に定義(固定設定)
!
interface FastEthernet0/12
 switchport mode dynamic desirable
 channel-group 1 mode on ←このポートをEtherChannelグループ1に定義(固定設定)
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
line vty 0 4
 no login
line vty 5 15
 no login
!
end
確認
複数のリンクを束ねて一つのリンクとして使う技術がEtherChannelです。
一般的に「リンク・アグリゲーション」と呼ばれている技術です。
帯域アップと冗長化の二つのメリットがあります。

●EtherChannelを固定設定する
EtherChannelを実現する方法は,以下の三の方法があります。

・固定的(強制的)に設定する
・PAgPというシスコ独自のプロトコルを使う
・LACPというIEEE802.3ad標準のプロトコルを使う

ここでは,固定的に設定する方法を見てみましょう。

●設定の確認
EtherChannelを設定するときは,インタフェースに対して,チャネル・グループ番号を設定します。
このラボ・シナリオ場合は,Fa0/11とFa0/12に対して,チャネル・グループ1番を設定します。
このとき,固定で(強制的に)EtherChannelを実行するときは,モードをonにします。
SwitchA(config)#interface range fastEthernet 0/11 - 12
SwitchA(config-if)#channel-group 1 mode on
SwitchBの設定も同様です。
すると,Fa0/11とFa0/12が,Port-channel1というインタフェースに自動的に割り当てられます。

●動作の確認
SwitchAとSwitchBに上記の設定を済ませた後の動作を見てみましょう。
EtherChannelの確認コマンドは,show etherchannelコマンドです。
SwitchA#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Fa0/11(P)   Fa0/12(P)
一番下に表示されたのが,Po1(Port-Channel1)インタフェースの状態です。
Po1(SU)の「S」がレイヤー2(Layer 2)のチャネルであることを示し,「U」が利用中(in use)であることを示しています。
右の「Ports」の項目にあるFa0/11とFa0/12が,Po1を構成する物理インタフェースです。
それぞれにある(P)印の「P」は,利用中(in port-channel)であることを示しています。

では,Port-channel1インタフェースの様子も見てみましょう。
チャネル化した論理インタフェース(Po1)の扱いは,物理インタフェースの扱いと全く同じです。
show interfaceコマンドで,インタフェースの様子を確認することができます。
見ると,up/upとなっており,きちんと動作していることがわかります。
SwitchA#show interfaces port-channel 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 000e.d7f6.918b (bia 000e.d7f6.918b)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Fa0/11 Fa0/12
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:08:18, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 3000 bits/sec, 4 packets/sec
  5 minute output rate 2000 bits/sec, 2 packets/sec
     17554 packets input, 1729776 bytes, 0 no buffer
     Received 14376 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 14335 multicast, 0 pause input
     0 input packets with dribble condition detected
     7255 packets output, 774714 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
ではでは,チャネル化した論理インタフェースであるPo1の,ポートの役割を見てみましょう。
すると,トランク・ポートになっているのがわかります。
SwitchA#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
念のため,show interface trunkで,トランク・ポートを調べてみましょう。
すると,Po1が表示されています(下の赤字)。
チャネル化されたPo1ポートも,通常の物理ポートと扱いは同じというわけですね。
SwitchA#show interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         desirable    n-isl          trunking      1

Port      Vlans allowed on trunk
Po1         1-4094

Port        Vlans allowed and active in management domain
Po1         1,10

Port        Vlans in spanning tree forwarding state and not pruned
Po1         1,10
では,スパニング・ツリーにおけるPo1の扱いはどうなっているでしょうか。
show spanning-treeコマンドで見てみましょう。
SwitchA#show spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     000e.d7f6.9180
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     000e.d7f6.9180
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Po1              Desg FWD 12        128.65   P2p
「Interface」の項目に「Po1」が表示されているのがわかります。
こちらも,物理インタフェースと同様にチャネル化したポートを扱っているのがわかります。

●冗長化の確認
では,チャネルを構成しているSwitchAのFa0/12ポートを意図的に抜いてみましょう。
すると,Fa0/12がダウンしたメッセージが出ます。
SwitchA#
01:20:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, chan
ged state to down
01:20:37: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to down
この状態で,チャネルの状態を見てみます。
SwitchA#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Fa0/11(P)   Fa0/12(D)
Fa0/12のフラグが「D」(down)となり,ダウンしたことがわかります。
しかし,Po1は「SU」のままであり,稼働中であることを示しています。
残り1本であるFa0/11が頑張っているわけですね。

では,残りの1本であるFa0/11も抜いてみます。
すると,Port-channel1がダウンしたことを示すメッセージが出ます(下の赤字)。
チャネルを構成する物理ポートが全部ダウンしたので,Po1自体がダウンしてしまったわけですね。
01:21:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/11, chan
ged state to down
01:21:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to down
01:21:24: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to down
01:21:24: %LINK-3-UPDOWN: Interface Port-channel1, changed state to down
この状態で,再びチャネルの状態を見てみます。
SwitchA#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)          -        Fa0/11(D)   Fa0/12(D)
Fa0/11とFa0/12の二つが「D」(down)となり,Po1が「SD」(Layer2でdown)となりました。
これを見ても,Po1自体がダウンしていることがわかります。

Fa0/12をポートにつないでみましょう。
すると,Fa0/12ポートがアップするメッセージが出た後に,Po1がアップするメッセージも出ます(下の赤字)。
SwitchA#
01:23:19: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
01:23:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, chan
ged state to up
01:23:22: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
01:23:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up
EtherChannelを使ってポートをチャネル化すると,論理インタフェース(Po1など)ができて,その論理インタフェースは物理インタフェースと同様に扱えるようになることがわかりました。

●Catalyst 3550 マルチレイヤ スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEC
http://www.cisco.com/japanese/warp/public/3/jp/service/manual_j/sw/cat30/3550mscg/chapter30/16610_03_30.shtml

スイッチング・ラボ
IEEE802.1X認証の基本設定
IEEE802.1X認証(認証VLAN)
EtherChannel(固定設定)
EtherChannel(PAgP)
EtherChannel(LACP)
EtherChannel(レイヤー3)
SPAN