Ciscoルーターをフレームリレー・スイッチにする
・Ciscoルーターをフレームリレー交換機に設定する
・RouterAとRouterBがフレームリレーで通信できていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
FRSWのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRSW
!
frame-relay switching ←このルーターをフレームリレー交換機として動作させる
!
interface Serial0
 no ip address
 encapsulation frame-relay ←レイヤー2のカプセル化にフレームリレーを使う
 clockrate 64000
 frame-relay intf-type dce ←このインタフェースをDCE(クロック供給側)とする
 frame-relay route 100 interface Serial1 200 ←DLCI100のデータをSerial1のDLCI200へ
!
interface Serial1
 no ip address
 encapsulation frame-relay ←レイヤー2のカプセル化にフレームリレーを使う
 clockrate 64000
 frame-relay intf-type dce ←このインタフェースをDCE(クロック供給側)とする
 frame-relay route 200 interface Serial0 100 ←DLCI200のデータをSerial0のDLCI100へ
!
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterAのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay ←レイヤー2のカプセル化にフレームリレーを使う
!
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterBのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay ←レイヤー2のカプセル化にフレームリレーを使う
!
line con 0
line aux 0
line vty 0 4
 login
!
end
確認
シスコ・ルーターは,自身をフレームリレー・スイッチ(フレームリレー交換機)にする機能を持っています。
この機能を使って,フレームリレーの通信を実践してみましょう。


●フレームリレーとは?
フレームリレーは,レイヤー2レベルのデータ転送技術です。
広域イーサネットやIP-VPNといったWANサービスが出る前までは,企業ネットワークにおけるWAN技術の主流でした。
現在は主回線として使われることはあまりありませんが,シスコ試験ではまだよく出てくる技術です。
フレームリレーの特徴は,物理回線上に仮想回線(VC:virtual circuit)を作り,そのVCを単位にデータをやりとりするところです。
一つの物理回線上に複数のVCを作成することも可能で,DLCI(Data Link Connection Identifier)という情報を使ってVCを識別します。

【フレームリレーで使われる用語】
・フレームリレー交換機…フレームリレー網を構成する機器
・VC…仮想回線。あらかじめVCを固定的に決めておくため「PVC」(Permanent Virtual Circuit)とも言われる。
・DLCI…VCを識別するための識別子
・LMI…ルーター(DTE)とフレームリレー交換機(DCE)の間で,フレームリレー網の状態や,VCの状態を確認するための機能。Local Management Interface。

LMIは,cisco,ansi,q933aという三つのタイプがあり,シスコ・ルーターでそれぞれを設定できます。
ただし,IOS11.2以降ではLMIタイプを自動検出できるようになっており,LMI方式を何も設定しなかった場合はcisco方式がデフォルトで動作します


●設定の確認
何はともあれ,まずはルーター同士をフレームリレーで通信させてみましょう。
そのためにまず,ルーター1台をフレームリレー交換機として動作させます。

フレームリレー交換機にするルーターには,「frame-relay switching」というコマンドを入れます。
FRSW(config)#frame-relay switching
続いて,インタフェースの設定に移ります。
インタフェースでは,以下の三つを設定します。
(1) フレームリレーのカプセル化を有効にする
(2) インタフェースをDCEに定義する
(3)「どのDLCIから入ってきたトラフィックをどのインタフェースのDLCIに出すのか」を決める

具体的には,このシナリオのケースのSerial0は,以下のようになります。
(3)は,「DLCI100から入ってきたトラフィックは,Serial1のDLCI200へ出せ」という意味です。
FRSW(config)#interface serial 0
FRSW(config-if)#encapsulation frame-relay ←(1)
FRSW(config-if)#frame-relay intf-type dce ←(2)
FRSW(config-if)#frame-relay route 100 interface Serial1 200←(3)
それに対してSerial1は以下です。
こちらは,「DLCI200から入ってきたトラフィックは,Serial0のDLCI100へ出せ」という意味です。
FRSW(config)#interface serial 1
FRSW(config-if)#encapsulation frame-relay ←(1)
FRSW(config-if)#frame-relay intf-type dce ←(2)
FRSW(config-if)#frame-relay route 200 interface Serial0 100←(3)
これで,フレームリレー網内のPVCが設定できました。
RouterAとRouterBの間を仮想回線(PVC)でつないだわけです。
以上が,フレームリレー交換機の設定です。


●動作の確認
フレームリレー交換機の設定を確認してみましょう。
入出力インタフェースとDLCIの対応は,show frame-relay routeコマンドで確認できます。
FRSW#show frame-relay route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0         100             Serial1         200             active
Serial1         200             Serial0         100             active
例えば1行目は,左から右へ「Serial0」のDLCI「100」から入ってきたトラフィックは,「Serial1」のDLCI「200」に出す,と読めばOKです。
また,二つともStatusが「active」になっており,きちんと動作していることがわかります。

RouterAとRouterBの設定は,フレームリレー交換機とつながっているインタフェース(Serial0/0)に,
・IPアドレス
・encapsulation frame-relayコマンド
の二つを設定しておきます。

設定したら,RouterAからRouterBにpingを打ってみましょう。
RouterA#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
きちんと返答が返ってきます。
フレームリレー交換機を介して,フレームリレーによる通信ができました。

フレームリレー・ラボ
Ciscoルーターをフレームリレー・スイッチにする
フレームリレー・マップ
ハブ・アンド・スポーク
サブインタフェース(point-to-point)
サブインタフェース(multipoint)
DEビットの設定
フレームリレー・トラフィックシェーピング
(ツール)トラフィック配信ツールでQoSの検証