サブインタフェース(multipoint)
・サブインタフェースのmultipointタイプを使い,point-to-pointタイプと組み合わせてルーティング(EIGRP)する
・スポーク・ルーター(RouterB,RouterC,RouterD)同士で通信できることを確認する
ネットワーク構成(画像を別ウインドウで表示)
FRSWのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRSW
!
frame-relay switching
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 120 interface Serial1 210
 frame-relay route 130 interface Serial2 310
 frame-relay route 140 interface Serial3 410
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 210 interface Serial0 120
!
interface Serial2
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 310 interface Serial0 130
!
interface Serial3
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 410 interface Serial0 140
!
line con 0
line aux 0
line vty 0 4
 login    
!
end
RouterAのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint ←サブインタフェースSerial0/0.1を作成
 ip address 192.168.1.1 255.255.255.0
 no ip split-horizon eigrp 1 ←EIGRPのスプリットホライズンを無効にする
 frame-relay map ip 192.168.1.2 120 broadcast ←フレームリレー・マップを設定
 frame-relay map ip 192.168.1.3 130 broadcast ←フレームリレー・マップを設定
!
interface Serial0/0.2 point-to-point ←サブインタフェースSerial0/0.2を作成
 ip address 192.168.2.1 255.255.255.0
 frame-relay interface-dlci 140 ←フレームリレー・マップを設定
!
router eigrp 1 ←EIGRPでルーティング
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterBのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 210 broadcast
 frame-relay map ip 192.168.1.3 210 broadcast
!
router eigrp 1 ←EIGRPでルーティング
 network 2.0.0.0
 network 192.168.1.0
 no auto-summary
!         
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterCのコンフィグ
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterC
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.1 210 broadcast
 frame-relay map ip 192.168.1.2 310 broadcast
!
router eigrp 1 ←EIGRPでルーティング
 network 3.0.0.0
 network 192.168.1.0
 no auto-summary
!
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterDのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface Serial0/0
 ip address 192.168.2.2 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay interface-dlci 410
!
router eigrp 1 ←EIGRPでルーティング
 network 4.0.0.0
 network 192.168.2.0
 no auto-summary
!
line con 0
line aux 0
line vty 0 4
!
end
確認
フレームリレーのサブインタフェースには,point-to-pointタイプとmultipointタイプの二つがあります。
ここでは,一つのサブインタフェースに複数のPVCを収容できるmultipointタイプを試してみましょう。

●サブインタフェースのタイプ
フレームリレーのサブインタフェースには,以下の二つのタイプがあります。

【サブインタフェースの二つのタイプ】
・point-to-pointタイプ…通信する相手のルーターが一つのとき
・multipointタイプ………通信する相手のルーター複数あるとき

このラボ・シナリオでは,multipointの内容を中心に見ていきましょう。


●設定の確認
RouterAのインタフェースの設定は以下のようになります。
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint
 ip address 192.168.1.1 255.255.255.0
 no ip split-horizon eigrp 1
 frame-relay map ip 192.168.1.2 120 broadcast
 frame-relay map ip 192.168.1.3 130 broadcast
!
interface Serial0/0.2 point-to-point
 ip address 192.168.2.1 255.255.255.0
 frame-relay interface-dlci 140
青字の部分は,point-to-pointサブインタフェースの設定です。
point-to-pointサブインタフェースでは,frame-relay interface-dlciコマンドを使って,PVCのDLCI値を指定してやります。
(point-to-pointサブインタフェースについては,サブインタフェース(point-to-point)を参照してください。)

赤字の部分がmultipointサブインタフェースの設定です。
こちらは,frame-relay mapコマンドを使って,DLCIとIPアドレスを対応付けています。
multipointサブインタフェース
ここでは,「192.168.1.2あてのパケットはDLCI120に出す」,「192.168.1.2あてのパケットはDLCI120に出す」という二つのPVCを設定しているわけです。
また,broadcastオプションを付けることで,ブロードキャストやマルチキャストのパケットをPVCに流せるようになります。
EIGRPやOSPFはマルチキャストを使って経路情報をやりとりするので,ルーティングする際には必須のオプションです。

このように,multipointサブインタフェースで複数のPVCを設定した場合,注意することがあります。
それは,一つのサブインタフェースに複数のPVCがあるということは,スプリット・ホライズンが効いてしまうため,EIGRPではサブインタフェース内のPVC同士で経路情報をやりとりできなくなってしまうということです。
これは,物理インタフェースに複数のPVCを設定した(「ハブ・アンド・スポーク」のラボ構成)のと同じです。
そこでここでは,multipointインタフェースのスプリットホライズンを無効にすることで解決しています。
それが上のno ip split-horizon eigrp 1の設定です。

この設定をしたRouterAの様子を図に表すと,以下のようになります。



●動作の確認
設定したら,動作を確認しましょう。
RouterBからRouterDまでpingを打ってみます。
RouterB#ping 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/112/112 ms
きちんと応答が返ってきました。
このときのパケット転送の動作を,ルーターの気持ち(?)になって追ってみましょう。
pingを送出するRouterBから見てみます。

RouterBは,RouterD(4.4.4.4)あてパケットの送出先を考える必要があります。
そこでルーティング・テーブルを見ます。
RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2809856] via 192.168.1.1, 6d00h, Serial0/0
     4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/2809856] via 192.168.1.1, 6d00h, Serial0/0
C    192.168.1.0/24 is directly connected, Serial0/0
D    192.168.2.0/24 [90/2681856] via 192.168.1.1, 6d00h, Serial0/0
「4.4.4.0/24あてのパケットは,192.168.1.1に送れ」とあります。
次に,192.168.1.1あてにパケットを送る際には,どのDLCIに出せばいいのかを考える必要があります。
そこで今度は,フレームリレー・マップを見てみます。
RouterB#show frame-relay map
Serial1/0 (up): ip 192.168.1.1 dlci 210(0xD2,0x3420), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.168.1.3 dlci 210(0xD2,0x3420), static,
              broadcast,
              CISCO, status defined, active
「192.168.1.1あてのパケットはDLCI210に出せ」とあります。
そこでRouterBは,IPパケットをフレームリレー形式のフレームでカプセル化して,DLCI210に送り出します。

パケットが192.168.1.1(RouterA)に到着しました。
パケットを受け取ったRouterAは,このパケットの送出先を考えなければいけません。
そこで,ルーティング・テーブルを見ます。
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 192.168.1.2, 6d00h, Serial0/0.1
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2297856] via 192.168.1.3, 6d00h, Serial0/0.1
     4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/2297856] via 192.168.2.2, 6d00h, Serial0/0.2
C    192.168.1.0/24 is directly connected, Serial0/0.1
C    192.168.2.0/24 is directly connected, Serial0/0.2
「4.4.4.0/24あてのパケットは,Serial0/0.2インタフェースから,192.168.2.2あてに出せ」とあります。
次に,192.168.2.2あてにパケットを送る際には,どのDLCIに出せばいいのかを考えます。
フレームリレー・マップを見てみます。
RouterA#show frame-relay map
Serial0/0.1 (up): ip 192.168.1.2 dlci 120(0x78,0x1C80), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.1 (up): ip 192.168.1.3 dlci 130(0x82,0x2020), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.2 (up): point-to-point dlci, dlci 140(0x8C,0x20C0), broadcast
          status defined, active
「Serial0/0.2は,point-to-pointインタフェースで,DLCIは140」とあります。
point-to-pointインタフェースは,接続相手が決まっているので,DLCI140に送り出すしかないわけです。
ということでRouterAは,IPパケットをフレームリレー形式のフレームでカプセル化して,DLCI140に送り出します。
するとパケットは,RouterDに到着します。

パケットを受け取ったRouterDは,このパケットの送出先を考えなければいけません。
そこでRouterDは,ルーティング・テーブルを見ます。
RouterD#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2809856] via 192.168.2.1, 6d01h, Serial0/0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2809856] via 192.168.2.1, 6d01h, Serial0/0
     4.0.0.0/24 is subnetted, 1 subnets
C       4.4.4.0 is directly connected, Loopback0
D    192.168.1.0/24 [90/2681856] via 192.168.2.1, 6d01h, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/0
「4.4.4.4/24のネットワークは,loopback0に直接つながっている」とあります。
4.4.4.4は,自身のloopbackアドレスです。
これで目的地にパケットが届いたわけです。

IPアドレスとDLCIの関係や,フレームリレー・マップの必要性が確認できたのではないでしょうか。

フレームリレー・ラボ
Ciscoルーターをフレームリレー・スイッチにする
フレームリレー・マップ
ハブ・アンド・スポーク
サブインタフェース(point-to-point)
サブインタフェース(multipoint)
DEビットの設定
フレームリレー・トラフィックシェーピング
(ツール)トラフィック配信ツールでQoSの検証