ハブ・アンド・スポーク
・フレームリレー・マップを使って,スポーク・ルーターであるRouterBとRouterC同士を通信できるようにする
・RouterBからRouterCへ通信できるようになったことを確認する
ネットワーク構成(画像を別ウインドウで表示)
FRSWのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRSW
!
frame-relay switching
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 120 interface Serial1 210
 frame-relay route 130 interface Serial2 310
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 210 interface Serial0 120
!
interface Serial2
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 310 interface Serial0 130
!         
line con 0
line aux 0
line vty 0 4
 login
!
end
RouterAのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
!
line con 0
line aux 0
line vty 0 4
 login
!         
end
RouterBのコンフィグ
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!         
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.3 210 ←192.168.1.3あてのパケットはDLCI210へ送出
!
line con 0
line aux 0
line vty 0 4
 login
!         
end
RouterCのコンフィグ
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterC
!
interface Serial0/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.1.2 310 ←192.168.1.2あてのパケットはDLCI310へ送出
!
line con 0
line aux 0
line vty 0 4
 login
!
end
確認
ネットワークの構成がハブ・アンド・スポークの状態で,スポーク同士のルーターの通信をさせてみましょう。
PVCをフルメッシュに確立しなくても,各ルーターに通信できるようにします。


●ハブ・アンド・スポークとは?
frame-relay mapコマンドは,IPアドレスとDLCI番号を手動で対応付ける機能です。
(一つ前の「フレームリレー・マップ」のラボ・シナリオを参照)。
この機能を使えば,フレームリレーにおいて「ハブ・アンド・スポーク」の通信を実現できます。
ハブ・アンド・スポークとは,一つの拠点に他の拠点が複数つながる構成のことです。
つまりこのラボ・シナリオでは,全拠点同士でPVCをフルメッシュで確立せずに,全拠点同士の通信を可能にします。

RouterAとRouterBにframe-relay mapコマンドを入れていない状態から見てみます。


●PVCを確認
まず,フレームリレー・スイッチに設定されているDLCIの状態を見てみましょう。
すべてのDLCIが「active」になって,正常に動作しています。
FRSW#show frame-relay route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0         120             Serial1         210             active
Serial0         130             Serial2         310             active
Serial1         210             Serial0         120             active
Serial2         310             Serial0         130             active
次に,それぞれのルーターのIPアドレスとDLCIの対応を確認してみます。
まずはハブ・ルーターであるRouterAを見てみます。
RouterA#show frame-relay map
Serial0/0 (up): ip 192.168.1.2 dlci 120(0x78,0x1C80), dynamic,
              broadcast,, status defined, active
Serial0/0 (up): ip 192.168.1.3 dlci 130(0x82,0x2020), dynamic,
              broadcast,, status defined, active
192.168.1.2がDLCI120に対応付けられており,192.168.1.3がDLCI130に対応付けられているのがわかります。
つまりRouterAは,「パケットを192.168.1.2(RouterB)に送信するときは,自身のDLCI120に送出すればよい」と理解しているわけです。
同様に,「パケットを192.168.1.3(RouterC)に送信するときは,自身のDLCI130に送出すればよい」と理解しています。
どちらも「dynamic」となっており,インバースARPを使って対応付けが実行されたことがわかります。

RouterBも見てみます。
RouterB#show frame-relay map
Serial0/0 (up): ip 192.168.1.1 dlci 210(0xD2,0x3420), dynamic,
              broadcast,, status defined, active
192.168.1.1がDLCI210に対応付けられているのがわかります。

RouterCはどうでしょうか。
RouterC#show frame-relay map
Serial0/0 (up): ip 192.168.1.1 dlci 310(0x136,0x4C60), dynamic,
              broadcast,, status defined, active
192.168.1.1がDLCI310に対応付けられているのがわかります。


●疎通確認
pingコマンドを使って,各ルーターへの疎通を確認してみます。
スポーク・ルーターであるRouterBから,ハブ・ルーターであるRouterAにpingを打ってみます。
RouterB#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms
応答が返ってきました。
疎通OKです。

では,RouterBから,今度はもう一つのハブ・ルーターであるRouterCにpingを打ってみます。
RouterB#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
応答が返ってきません。
通信できない状態です。

なぜ通信できないか,原因を調べてみましょう。
debugコマンドを使って,フレーム・リレーでやりとりされているパケットを細かく見てみます。
RouterBにdebugコマンドを入れて,RouterCにpingを打ちます。
RouterB#debug frame-relay packet
Frame Relay packet debugging is on
RouterB#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

02:31:01: Serial0/0:Encaps failed--no map entry link 7(IP).
02:31:03: Serial0/0:Encaps failed--no map entry link 7(IP).
02:31:05: Serial0/0:Encaps failed--no map entry link 7(IP).
02:31:07: Serial0/0:Encaps failed--no map entry link 7(IP).
02:31:09: Serial0/0:Encaps failed--no map entry link 7(IP).
Success rate is 0 percent (0/5)
「Encaps failed--no map entry」というエラー・メッセージが表示されました。
これは,「フレームリレー・マップがないのでカプセル化に失敗した」というメッセージです。
つまり,192.168.1.3へパケットを送るためのフレームリレー・マップの設定がないので,IPパケットをフレームリレーのフレームでカプセル化できなかったというわけです。

●フレームリレー・マップを設定する
では,RouterBにフレームリレー・マップを設定してみましょう。
RouterBのSerial0/0に「192.168.1.3あてのパケットはDLCI210に送出」という設定をしてやります。
RouterB(config)#interface serial 0/0
RouterB(config-if)#frame-relay map ip 192.168.1.3 210
設定したら,再びRouterC(192.168.1.3)にpingを打ってみます。
RouterB#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

02:35:57: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104.
02:35:59: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104.
02:36:01: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104.
02:36:03: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104.
02:36:05: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104.
Success rate is 0 percent (0/5)
まだ通信できません。
ただ,(o)印のメッセージが五つ出ました。
(o)印は,送信(out)パケットを表しています。
つまり,送信は正しくできているけど,受信ができていないというわけです。

それもそのはず,まだRouterCにフレームリレー・マップを設定していません。
そこで,RouterCにもフレームリレー・マップを設定してみましょう。
「192.168.1.2あてのパケットはDLCI310に送出」と設定します。
RouterC(config)#interface serial 0/0
RouterC(config-if)#frame-relay map ip 192.168.1.2 310
設定したら,再びRouterBからRouterCにpingを打ってみます。
RouterB#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/116/124 ms
RouterB#
02:38:09: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104
02:38:09: Serial0/0(i): dlci 210(0x3421), pkt type 0x800, datagramsize 104
02:38:09: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104
02:38:10: Serial0/0(i): dlci 210(0x3421), pkt type 0x800, datagramsize 104
02:38:10: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104
02:38:10: Serial0/0(i): dlci 210(0x3421), pkt type 0x800, datagramsize 104
02:38:10: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104
02:38:10: Serial0/0(i): dlci 210(0x3421), pkt type 0x800, datagramsize 104
02:38:10: Serial0/0(o): dlci 210(0x3421), pkt type 0x800(IP), datagramsize 104
02:38:10: Serial0/0(i): dlci 210(0x3421), pkt type 0x800, datagramsize 104
今度は,5個のパケットすべて応答が返ってきました。
送信パケット(o)に加えて,受信パケット(i)も表示されているのがわかります。

最後に,RouterBとRouterCのフレームリレー・マップの状態を確認しておきましょう。
RouterBのフレームリレー・マップが以下です。
RouterB#show frame-relay map
Serial0/0 (up): ip 192.168.1.1 dlci 210(0xD2,0x3420), dynamic,
              broadcast,, status defined, active
Serial0/0 (up): ip 192.168.1.3 dlci 210(0xD2,0x3420), static,
              CISCO, status defined, active
インバースARPを使って設定されたエントリ(dynamic)と,手動で設定したエントリ(static)の二つのエントリができているのがわかります。

RouterC#show frame-relay map
Serial0/0 (up): ip 192.168.1.2 dlci 310(0x136,0x4C60), static,
              CISCO, status defined, active
Serial0/0 (up): ip 192.168.1.1 dlci 310(0x136,0x4C60), dynamic,
              broadcast,, status defined, active
RouterCも同様に,二つのエントリができているのがわります。

フレームリレー・ラボ
Ciscoルーターをフレームリレー・スイッチにする
フレームリレー・マップ
ハブ・アンド・スポーク
サブインタフェース(point-to-point)
サブインタフェース(multipoint)
DEビットの設定
フレームリレー・トラフィックシェーピング
(ツール)トラフィック配信ツールでQoSの検証